summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml51
1 files changed, 13 insertions, 38 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index 253d99d..92b16cc 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -7,52 +7,27 @@ documentation = "https://docs.rs/ipfs-api"
repository = "https://github.com/ferristseng/rust-ipfs-api"
keywords = ["ipfs"]
categories = ["filesystem", "web-programming"]
-version = "0.11.0"
+version = "0.12.0"
readme = "../README.md"
license = "MIT OR Apache-2.0"
[features]
-default = ["with-hyper-tls", "with-builder"]
-with-hyper-tls = ["with-hyper", "hyper-tls"]
-with-hyper-rustls = ["with-hyper", "hyper-rustls"]
-with-hyper = ["hyper", "hyper-multipart-rfc7578", "failure"]
-with-actix = ["actix-http", "actix-multipart-rfc7578", "awc", "derive_more"]
-with-builder = ["typed-builder"]
+default = ["with-hyper", "with-builder"]
+with-hyper-tls = ["with-hyper", "ipfs-api-backend-hyper/with-hyper-tls"]
+with-hyper-rustls = ["with-hyper", "ipfs-api-backend-hyper/with-hyper-rustls"]
+with-hyper = ["ipfs-api-backend-hyper"]
+with-actix = ["ipfs-api-backend-actix"]
+with-builder = ["ipfs-api-prelude/with-builder"]
# Old features, kept for compatibility
actix = ["with-actix"]
builder = ["with-builder"]
[dependencies]
-actix-http = { version = "2.2", optional = true }
-actix-multipart-rfc7578 = { version = "0.4", optional = true }
-awc = { version = "2.0", optional = true }
-bytes = "1.0"
-derive_more = { version = "0.99", optional = true }
-failure = { version = "0.1", optional = true }
-futures = "0.3"
-http = "0.2"
-hyper = { version = "0.14", features = ["http1", "http2", "client"], optional = true }
-hyper-tls = { version = "0.5", optional = true }
-hyper-rustls = { version = "0.22", optional = true }
-hyper-multipart-rfc7578 = { version = "0.5", optional = true }
-serde = { version = "1.0", features = ["derive"] }
-serde_json = "1.0"
-serde_urlencoded = "0.7"
-tokio = "1.2"
-tokio-util = { version = "0.6", features = ["codec"] }
-tracing = "0.1"
-walkdir = "2.3"
-dirs = "3.0"
-parity-multiaddr = "0.11"
-typed-builder = { version = "0.9", optional = true }
+ipfs-api-prelude = { version = "0.1", path = "../ipfs-api-prelude" }
+ipfs-api-backend-actix = { version = "0.1", path = "../ipfs-api-backend-actix", optional = true }
+ipfs-api-backend-hyper = { version = "0.1", path = "../ipfs-api-backend-hyper", optional = true }
[dev-dependencies]
-actix-http = "2.2"
-actix-rt = "1.0"
-awc = "2.0"
-hyper = "0.14"
-hyper-tls = "0.5"
-tar = "0.4"
-tokio = { version = "1.2", features = ["rt-multi-thread", "macros", "time"] }
-tokio-stream = { version = "0.1", features = ["time"] }
-tracing-subscriber = { version = "0.2", features = ["fmt"] }
+actix-rt = "2.0"
+futures = "0.3"
+tokio = { version = "1", features = ["rt-multi-thread", "macros"] }