summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index b216fae..76deb6e 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -17,6 +17,7 @@ travis-ci = { repository = "ferristseng/rust-ipfs-api" }
[features]
default = ["hyper", "hyper-multipart-rfc7578", "hyper-tls", "failure"]
actix = ["actix-http", "actix-multipart-rfc7578", "awc", "derive_more"]
+builder = ["typed-builder"]
[dependencies]
actix-http = { version = "1.0", optional = true }
@@ -38,6 +39,7 @@ tokio-util = { version = "0.2", features = ["codec"] }
walkdir = "2.2"
dirs = "2.0"
parity-multiaddr = "0.7.3"
+typed-builder = { version = "0.6", optional = true }
[dev-dependencies]
actix-http = "1.0"