summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
authorFerris Tseng <ferristseng@fastmail.fm>2021-02-14 00:31:14 -0500
committerFerris Tseng <ferristseng@fastmail.fm>2021-02-14 00:31:14 -0500
commit548304fd69614479790c36ddb0615599df0130b2 (patch)
treedb0534ba6575e9ad897f6554ff41cddfdcc4ca7c /ipfs-api/Cargo.toml
parent5fe7c4f8bae147db49aaa275fe540b2b4667b3a1 (diff)
add tracing
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index b165c11..3902235 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -43,6 +43,7 @@ serde_json = "1.0"
serde_urlencoded = "0.7"
tokio = "1.2"
tokio-util = { version = "0.6", features = ["codec"] }
+tracing = "0.1"
walkdir = "2.3"
dirs = "3.0"
parity-multiaddr = "0.11"
@@ -57,3 +58,4 @@ hyper-tls = "0.5"
tar = "0.4"
tokio = { version = "1.2", features = ["rt-multi-thread", "macros", "time"] }
tokio-stream = { version = "0.1", features = ["time"] }
+tracing-subscriber = { version = "0.2", features = ["fmt"] }