summaryrefslogtreecommitdiffstats
path: root/ipfs-api-backend-actix/Cargo.toml
diff options
context:
space:
mode:
authorFerris Tseng <ferristseng@fastmail.fm>2021-04-04 20:06:34 -0400
committerGitHub <noreply@github.com>2021-04-04 20:06:34 -0400
commit799f702b22a9b567c0b6b7674210583b02b10d55 (patch)
tree92d7a1c9dcac42599357097c53caccfbdcaa8105 /ipfs-api-backend-actix/Cargo.toml
parent4c78f5759c60499eefd4527ea34d574c2fb35c14 (diff)
parent168f3a5e68780c37f4070ea9d42ac70bd0158292 (diff)
Merge pull request #72 from ferristseng/ftseng-divide-cratesHEADmaster
Divide backends into separate crates
Diffstat (limited to 'ipfs-api-backend-actix/Cargo.toml')
-rw-r--r--ipfs-api-backend-actix/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/ipfs-api-backend-actix/Cargo.toml b/ipfs-api-backend-actix/Cargo.toml
new file mode 100644
index 0000000..ef99591
--- /dev/null
+++ b/ipfs-api-backend-actix/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "ipfs-api-backend-actix"
+description = "Actix implementation of IPFS HTTP API"
+authors = ["Ferris Tseng <ferristseng@fastmail.fm>"]
+edition = "2018"
+documentation = "https://docs.rs/ipfs-api"
+repository = "https://github.com/ferristseng/rust-ipfs-api"
+keywords = ["ipfs"]
+categories = ["filesystem", "web-programming"]
+version = "0.1.0"
+readme = "../README.md"
+license = "MIT OR Apache-2.0"
+
+[dependencies]
+actix-http = "3.0.0-beta.5"
+actix-multipart-rfc7578 = "0.5"
+awc = "3.0.0-beta.4"
+async-trait = "0.1"
+bytes = "1.0"
+futures = "0.3"
+http = "0.2"
+ipfs-api-prelude = { version = "0.1.0", path = "../ipfs-api-prelude" }
+serde = "1.0"
+thiserror = "1.0"