summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-08-29 21:38:29 +0200
committerDave Davenport <qball@gmpclient.org>2016-08-29 21:38:29 +0200
commite79361e8904a2baa94e2a274bb72f9d95f3b8c02 (patch)
tree6573b4d3c0957b807286f74d5b3bf0caf0900c7e /configure.ac
parent5cfe9a89b326e582fdda81c03cc6efba8e1379cb (diff)
Fix configure script a bit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 15 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e0076887..1350d443 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,9 +54,11 @@ AC_ARG_ENABLE(asan,
[AM_CFLAGS="${AM_CFLAGS} -fsanitize=address -fno-omit-frame-pointer -g3"])
-AC_ARG_ENABLE(broken-drun,
- [ --enable-broken-drun drun],
- [AM_CFLAGS="${AM_CFLAGS} -DBROKEN_DRUN"])
+dnl --------------------------------------------------------------------
+dnl DRun dialog
+dnl --------------------------------------------------------------------
+AC_ARG_ENABLE([drun], AC_HELP_STRING([--enable-drun],[Enable desktop file run dialog]))
+AS_IF([test "x${enable_drun}" == "xyes"], [AC_DEFINE([ENABLE_DRUN], [1], [Enable desktop file run dialog])])
dnl ---------------------------------------------------------------------
dnl Disable window mode
dnl ---------------------------------------------------------------------
@@ -117,6 +119,16 @@ echo "Timing output: Enabled"
else
echo "Timing output: Disabled"
fi
+if test x$enable_drun = xyes; then
+echo "Desktop File run dialog Enabled"
+else
+echo "Desktop File run dialog Disabled"
+fi
+if test x$enable_windowmode != xno; then
+echo "Window Switcher dialog Enabled"
+else
+echo "Window Switcher dialog Disabled"
+fi
echo "-------------------------------------"
echo "Now type 'make' to build"
echo ""