summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-09-17 18:57:44 +0200
committerDave Davenport <qball@gmpclient.org>2016-09-17 18:57:44 +0200
commit5ee5bb1e23b303477c4335dd0ff412735152af5a (patch)
treeba06485a9dfa0a8db1daf862c333dc242eb5c56d /configure.ac
parent6191662ccf85af51bde7a44878aaf5aa0a23d166 (diff)
First rough version of async loading for dmenu.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3f103a88..2a0d444e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,7 +75,7 @@ dnl ---------------------------------------------------------------------
dnl Check for C functions.
dnl ---------------------------------------------------------------------
AC_CHECK_FUNC([getline],, AC_MSG_ERROR("Could not find getline in c library"))
-AC_CHECK_FUNC([getdelim],, AC_MSG_ERROR("Could not find getdelim in c library"))
+AC_CHECK_FUNC([open],, AC_MSG_ERROR("Could not find open in c library"))
AC_CHECK_FUNC([sysconf],, AC_MSG_ERROR("Could not find sysconf"))
AC_CHECK_FUNC([getenv],, AC_MSG_ERROR("Could not find getenv"))
AC_CHECK_FUNC([strtok_r],, AC_MSG_ERROR("Could not find strtok_r"))
@@ -93,7 +93,7 @@ PKG_PROG_PKG_CONFIG
dnl ---------------------------------------------------------------------
dnl PKG_CONFIG based dependencies
dnl ---------------------------------------------------------------------
-PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.40])
+PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.40 gio-unix-2.0])
GW_CHECK_XCB([xcb-aux xcb-xkb xkbcommon >= 0.5.0 xkbcommon-x11 xcb-ewmh xcb-icccm xcb-xrm xcb-randr xcb-xinerama])
PKG_CHECK_MODULES([pango], [pango pangocairo])
PKG_CHECK_MODULES([cairo], [cairo cairo-xcb])