summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-02-21 12:57:30 +0100
committerDave Davenport <qball@gmpclient.org>2016-02-21 12:57:30 +0100
commitd3a044db8e476744007da3246fd5e4a86efeff5a (patch)
treebb2482fd0cb1902c5db7e5660a49b54b77a0132a /Makefile.am
parent4c11da91f55a5e5922b0d1a537f2e086320a7d4a (diff)
Fixing make dist after merge of make cleanups.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 61a71247..084dbca4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,6 +137,16 @@ update-manpage: $(top_srcdir)/doc/rofi-manpage.markdown
##
check_PROGRAMS=rofi_test textbox_test helper_test
+rofi_test_CFLAGS=\
+ $(AM_CFLAGS)\
+ $(glib_CFLAGS)\
+ -I$(top_srcdir)/include/\
+ -I$(top_srcdir)/config/\
+ -I$(top_builddir)/
+
+rofi_test_LDADD=\
+ $(glib_LIBS)
+
rofi_test_SOURCES=\
source/history.c\
@@ -148,6 +158,24 @@ rofi_test_SOURCES=\
include/history.h\
test/history-test.c
+textbox_test_CFLAGS=\
+ $(AM_CFLAGS)\
+ $(glib_CFLAGS)\
+ $(pango_CFLAGS)\
+ $(x11_CFLAGS)\
+ $(xinerama_CFLAGS)\
+ $(cairo_CFLAGS)\
+ -I$(top_srcdir)/include/\
+ -I$(top_srcdir)/config/\
+ -I$(top_builddir)/
+
+textbox_test_LDADD=\
+ $(glib_LIBS)\
+ $(pango_LIBS)\
+ $(x11_LIBS)\
+ $(xinerama_LIBS)\
+ $(cairo_LIBS)
+
textbox_test_SOURCES=\
source/widget.c\
source/textbox.c\
@@ -180,6 +208,24 @@ helper_test_SOURCES=\
source/xrmoptions.c\
test/helper-test.c
+helper_test_CFLAGS=\
+ $(AM_CFLAGS)\
+ $(glib_CFLAGS)\
+ $(pango_CFLAGS)\
+ $(x11_CFLAGS)\
+ $(xinerama_CFLAGS)\
+ $(cairo_CFLAGS)\
+ -I$(top_srcdir)/include/\
+ -I$(top_srcdir)/config/\
+ -I$(top_builddir)/
+
+helper_test_LDADD=\
+ $(glib_LIBS)\
+ $(pango_LIBS)\
+ $(x11_LIBS)\
+ $(xinerama_LIBS)\
+ $(cairo_LIBS)
+
TESTS=\
rofi_test\
helper_test