summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorQuentin Glidic <sardemff7+git@sardemff7.net>2017-03-19 16:33:54 +0100
committerQuentin Glidic <sardemff7+git@sardemff7.net>2017-03-19 16:33:54 +0100
commita678204d0b69401766a3274eb2bfdc12cffc5af1 (patch)
tree4e0040aab52681e6241095e53e4e8fe5d3d45046 /Makefile.am
parent4ae414e3ab3931260dd0f025ef1f3ee12fea56ad (diff)
wayland: Initial API
Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 24 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a917f923..15f1f7c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,8 +36,11 @@ dist_bin_SCRIPTS=\
script/rofi-theme-selector
nodist_rofi_SOURCES=\
+ source/unstable/launcher-menu/launcher-menu-unstable-v1-protocol.c
$(top_builddir)/gitconfig.h
+rofi source/wayland.o: include/unstable/launcher-menu/launcher-menu-unstable-v1-client-protocol.h
+
SOURCES=\
source/rofi.c\
source/view.c\
@@ -55,6 +58,7 @@ SOURCES=\
source/widgets/listview.c\
source/widgets/scrollbar.c\
source/xrmoptions-dummy.c\
+ source/wayland.c\
source/x11-helper.c\
source/dialogs/run.c\
source/dialogs/ssh.c\
@@ -63,8 +67,7 @@ SOURCES=\
source/dialogs/combi.c\
source/dialogs/script.c\
source/dialogs/help-keys.c\
- include/xcb.h\
- include/xcb-internal.h\
+ include/wayland.h\
include/rofi.h\
include/mode.h\
include/mode-private.h\
@@ -511,3 +514,22 @@ coverage-clean:
.PHONY: .FORCE
.FORCE:
+
+# Wayland protocol code generation rules
+source/%-protocol.c: $(wpprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) code < $< > $@
+
+include/%-server-protocol.h: $(wpprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) server-header < $< > $@
+
+include/%-client-protocol.h: $(wpprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) client-header < $< > $@
+
+source/%-protocol.c: $(wwprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) code < $< > $@
+
+include/%-server-protocol.h: $(wwprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) server-header < $< > $@
+
+include/%-client-protocol.h: $(wwprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) client-header < $< > $@