summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2015-03-03 22:11:17 +0100
committerDave Davenport <qball@gmpclient.org>2015-03-03 22:11:17 +0100
commit94ae8d09e2e4f16961e227a2565658f457117474 (patch)
tree12ccba97c501187c0536c3f76c1845d62e01d130 /Makefile.am
parentab0f53caf6068546a1dc2a2ba72eada6d6f40155 (diff)
Move test with X stuff in test-x target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 30b611fc..0407fcbc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -139,6 +139,9 @@ helper_test_SOURCES=\
test: ${bin_PROGRAMS}
./rofi_test
./helper_test
+
+.PHONY: test-x
+test-x: ${bin_PROGRAMS}
$(top_srcdir)/test/run_test.sh 123 $(top_builddir)/textbox_test $(top_builddir) $(top_srcdir)/doc/example.xresources
$(top_srcdir)/test/run_test.sh 200 $(top_srcdir)/test/run_errormsg_test.sh $(top_builddir) $(top_srcdir)/doc/example.xresources
$(top_srcdir)/test/run_test.sh 201 $(top_srcdir)/test/run_switchdialog_test.sh $(top_builddir) $(top_srcdir)/doc/example.xresources