summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorduarm <mathdu@protonmail.com>2022-11-08 15:18:45 -0300
committerGitHub <noreply@github.com>2022-11-08 19:18:45 +0100
commit6d02648d3a2ab9ee9751db8783f00b14071f57b4 (patch)
treee556dc9fe0d8a0368def8a2bd46fe4544d36fbe3 /Makefile.am
parent579902deff5c23cf690fc76bb9bcdca4f511b0df (diff)
input method (#1735)
* input method draft * restoring relese event * using unused macro, removing debug code, handling disconnection * review fixes, new update_im_window_pos method * initializing variables correctly * initializing im pos queue correctly * ime window positioning * add widget_get_y_pos() position * [Build] Update makefile with imdkit * [CI] Add imdkit as dependency. * [XCB] rofi_view_paste don't throw warning, print debug. * [XCB] rofi_view_paste lower 'failed to convert selection' * [Build] Add minimum version check to imdkit * new macro XCB_IMDKIT_1_0_3_LOWER * [Build] Try to support old version of imdkit in meson/makefile. * [Build] Fix typo in meson.build * [XIM] Don't set use compound/set use utf8 when on old version. * [Build] Allow building without imdkit. * [Doc] Add imdkit to dependency list. Co-authored-by: Dave Davenport <qball@gmpclient.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 24e5526a..4e316e74 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -145,6 +145,7 @@ rofi_CFLAGS=\
$(libsn_CFLAGS)\
$(cairo_CFLAGS)\
$(gdkpixbuf_CFLAGS)\
+ $(imdclient_CFLAGS)\
-DMANPAGE_PATH="\"$(mandir)/\""\
-I$(top_srcdir)/include/\
-I$(top_builddir)/lexer/\
@@ -165,6 +166,7 @@ rofi_LDADD=\
$(pango_LIBS)\
$(cairo_LIBS)\
$(gdkpixbuf_LIBS)\
+ $(imdclient_LIBS)\
$(LIBS)
##