summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@blame.services>2022-05-25 18:21:27 +0200
committerDave Davenport <qball@blame.services>2022-05-25 18:21:27 +0200
commit3958f68ba40b4a3b41cdce18c1385f686ce1cc89 (patch)
treeb4d39613c4fd0d542ab99442afdcb8b1619c0f14 /Makefile.am
parent72a632bef5c42a1a78a9ae891c9d8ca78597e766 (diff)
[Build] Fix make based build with desktop file and icons.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b02e51e8..667e6273 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -625,6 +625,15 @@ coverage-clean:
.PHONY: .FORCE
.FORCE:
+icondir=$(datadir)/icons/hicolor/apps/
+icon_DATA=\
+ data/rofi.svg
+
+desktopdir=$(datadir)/applications/
+desktop_DATA=\
+ data/rofi.desktop\
+ data/rofi-theme-selector.desktop
+
EXTRA_DIST += \
doc/meson.build \
subprojects/libgwater/mpd/meson.build \
@@ -648,5 +657,9 @@ EXTRA_DIST += \
subprojects/libgwater/alsa-mixer/libgwater-alsa-mixer.h \
subprojects/libgwater/alsa-mixer/libgwater-alsa-mixer.c \
doc/meson_build_manpages.sh \
+ data/rofi.png\
meson_options.txt \
meson.build
+
+EXTRA_DIST += ${desktop_DATA}\
+ ${icon_DATA}