summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2017-09-29 18:44:21 +0200
committerDave Davenport <qball@gmpclient.org>2017-09-29 18:44:21 +0200
commit21e2e674129adb7f579b4edfe37bbeb75f936cc4 (patch)
tree35228c9b7e1ef8333f8a1ca0e1e2a55ab06f644b /Makefile.am
parentebffe5503d1709f00d4d7d85f0db4f8fe1dc4f42 (diff)
Make tokenize test use libcheck.
- Add some tests for negate.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 18 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index adf4d94c..35c5fbcd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -235,14 +235,13 @@ check_PROGRAMS+=\
helper_test\
helper_expand\
helper_pidfile\
- helper_tokenize\
helper_config_cmdline_parser\
widget_test\
box_test\
scrollbar_test
if USE_CHECK
-check_PROGRAMS+=mode_test theme_parser_test
+check_PROGRAMS+=mode_test theme_parser_test helper_tokenize
endif
@@ -316,22 +315,6 @@ helper_pidfile_SOURCES=\
source/xrmoptions.c\
test/helper-pidfile.c
-helper_tokenize_CFLAGS=$(textbox_test_CFLAGS)
-helper_tokenize_LDADD=$(textbox_test_LDADD)
-helper_tokenize_SOURCES=\
- config/config.c\
- include/rofi.h\
- include/mode.h\
- include/mode-private.h\
- source/helper.c\
- source/rofi-types.c\
- include/rofi-types.h\
- include/helper.h\
- include/helper-theme.h\
- include/xrmoptions.h\
- source/xrmoptions.c\
- test/helper-tokenize.c
-
widget_test_LDADD=$(textbox_test_LDADD)
widget_test_CFLAGS=$(textbox_test_CFLAGS)
widget_test_SOURCES=\
@@ -519,6 +502,22 @@ mode_test_SOURCES=\
source/keyb.c\
include/mode.h\
include/mode-private.h
+helper_tokenize_CFLAGS=$(textbox_test_CFLAGS) $(check_CFLAGS)
+helper_tokenize_LDADD=$(textbox_test_LDADD) $(check_LIBS)
+helper_tokenize_SOURCES=\
+ config/config.c\
+ include/rofi.h\
+ include/mode.h\
+ include/mode-private.h\
+ source/helper.c\
+ source/rofi-types.c\
+ include/rofi-types.h\
+ include/helper.h\
+ include/helper-theme.h\
+ include/xrmoptions.h\
+ source/xrmoptions.c\
+ test/helper-tokenize.c
+
endif
TESTS+=\
@@ -526,7 +525,6 @@ TESTS+=\
helper_test\
helper_expand\
helper_pidfile\
- helper_tokenize\
helper_config_cmdline_parser\
textbox_test\
widget_test\
@@ -535,6 +533,7 @@ TESTS+=\
if USE_CHECK
TESTS+=theme_parser_test\
+ helper_tokenize\
mode_test
endif