summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2016-02-27 11:07:26 -0500
committerAndrew Gallant <jamslam@gmail.com>2016-02-27 11:07:26 -0500
commit9d1e619ff359b6e609b02f01e36952e603104bc6 (patch)
treea97a9dd0cbbd0978e92971805431ea4f5c018808 /Cargo.toml
initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 00000000..e562a584
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "rep"
+version = "0.1.0" #:version
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+description = """
+Line oriented search tool using Rust's regex library.
+"""
+documentation = "https://github.com/BurntSushi/rep"
+homepage = "https://github.com/BurntSushi/rep"
+repository = "https://github.com/BurntSushi/rep"
+readme = "README.md"
+keywords = ["regex", "grep", "egrep", "search", "pattern"]
+license = "Unlicense/MIT"
+
+[dependencies]
+docopt = "0.6"
+regex = { version = "0.1", path = "/home/andrew/rust/regex" }
+rustc-serialize = "0.3"
+
+[profile.release]
+debug = true