summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2016-12-24 09:58:15 -0500
committerAndrew Gallant <jamslam@gmail.com>2016-12-24 09:58:15 -0500
commit9911cd0cd9569ef03255b5f1565d781a16d1cd9c (patch)
tree6850ef6cee6e33ab6480cfce8869b86bc46ece93 /Cargo.toml
parentde91c26bb1d4c910309c46c9158000daa7a09d40 (diff)
Remove ~ dependency on clap.
The point of the ~ dependency was to avoid implicitly increasing the minimum Rust version required to compile ripgrep. However, clap's policy is to support at least two prior releases of Rust (which roughly corresponds to the convention that others use too), and that is probably good enough. The problem with using a ~ dependency is that it can make packaging ripgrep in Linux distros difficult, because it means the packager may be forced to package multiple compatible versions of the same library. Fixes #271
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1043d083..a2bd2c57 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,7 +26,7 @@ path = "tests/tests.rs"
[dependencies]
bytecount = "0.1.4"
-clap = "~2.19.0"
+clap = "2.19.0"
ctrlc = "2.0"
env_logger = "0.3"
grep = { version = "0.1.4", path = "grep" }