summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-04-06 10:25:25 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-04-06 10:25:25 +0200
commitf27ff3c73f91e3c5821ed54bbc9b7e6f641dbf53 (patch)
treeed59bb1e2e8a5db37177ed9e216709fe37f33292 /shell.nix
parent9251445a5ac5315dca3921b7e77ce4a37cd42497 (diff)
parenta6caaff3c89bb21fd1ed83fae023bb7df9ce59b3 (diff)
Merge remote-tracking branch 'github/master'
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..80c97c2
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,25 @@
+{ ... }:
+
+let
+ moz_overlay = import (
+ builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz
+ );
+
+ pkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
+in
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ rustChannels.stable.rust-std
+ rustChannels.stable.rust
+ rustChannels.stable.rustc
+ rustChannels.stable.cargo
+
+ openssl
+ cmake
+ gcc
+
+ pkgconfig
+ ];
+ LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+}
+