summaryrefslogtreecommitdiffstats
path: root/librepology/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <matthias.beyer@atos.net>2019-05-02 16:21:11 +0200
committerMatthias Beyer <matthias.beyer@atos.net>2019-05-02 16:33:26 +0200
commit4d14473635b077755368c57497af9c20f9c30254 (patch)
treea66d56a7af492b8795ea3a992e138779e98103ba /librepology/Cargo.toml
parent2e825bdb04a5def0db592d45a8ffd6854d028329 (diff)
Revert "Add filters for Repo, Name, Status, Version, License and Maintainer"
We do not really need this feature in the library, authors of software can easily implement this for their needs and we do not have to ship all features all people _might_ use at some point. Keep the library KISSy. This reverts commit 44215217da63762b36827f5ef6604c5a2ad6b73d.
Diffstat (limited to 'librepology/Cargo.toml')
-rw-r--r--librepology/Cargo.toml8
1 files changed, 1 insertions, 7 deletions
diff --git a/librepology/Cargo.toml b/librepology/Cargo.toml
index 7dadd2f..3dccff0 100644
--- a/librepology/Cargo.toml
+++ b/librepology/Cargo.toml
@@ -25,12 +25,6 @@ url_serde = "0.2"
failure = "0.1"
log = "0.4"
derive_more = "0.14"
+derive-new = "0.5"
curl = "0.4"
-filters = { version = "0.3", optional = true }
-derive-new = { version = "0.5", optional = true }
-
-[features]
-# By default, we include the filters functionality
-default = [ "packagefilters" ]
-packagefilters = ["filters", "derive-new"]