summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Fink <werner@suse.de>2012-03-13 16:15:43 +0100
committerWerner Fink <werner@suse.de>2012-03-13 16:15:43 +0100
commit378eea8bd5db4ed8244ce1a3f416137f131acdd5 (patch)
treeac5efd347d52b9be448ce2b593b92327c3b24501 /configure.ac
parent54033e94bb8e038655f3241524da5616cb344435 (diff)
Use --enable-timeout-stat as well as --enable-timeout-stat=static
for a static background process which does the final stat system calls Signed-off-by: Werner Fink <werner@suse.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0615f5f..9265d82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,12 +30,16 @@ AC_SUBST([SELINUX_LIB])
# Call fork before all stat calls to stop hanging on NFS mounts
AC_SUBST([WITH_TIMEOUT_STAT])
AC_ARG_ENABLE([timeout_stat],
- [AS_HELP_STRING([--enable-timeout-stat], [Use a timeout on stat calls])],
+ [AS_HELP_STRING([--enable-timeout-stat], [Use a timeout on stat calls (optional with argument "static" for a static background process)])],
[enable_timeout_stat=$enableval],
[enable_timeout_stat="no"])
if test "$enable_timeout_stat" = "yes"; then
AC_DEFINE([WITH_TIMEOUT_STAT], [1], [Use timeout on stat calls])
fi
+if test "$enable_timeout_stat" = "static"; then
+ AC_DEFINE([WITH_TIMEOUT_STAT], [2], [Use timeout on stat calls])
+fi
+AM_CONDITIONAL([WANT_TIMEOUT_STAT], [test "$enable_timeout_stat" = "static"])
# Enable hardened compile and link flags
AC_ARG_ENABLE([harden_flags],