summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 6 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 942b589..46137d0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,6 +11,7 @@ authors = [ "Pierre-Henri Symoneaux" ]
keywords = ["tab", "table", "format", "pretty", "print"]
categories = ["command-line-interface"]
license = "BSD-3-Clause"
+edition = "2018"
[badges]
appveyor = { repository = "phsym/prettytable-rs", branch = "master", service = "github" }
@@ -23,15 +24,16 @@ win_crlf = []
[[bin]]
name = "main"
+edition = "2018"
path = "src/main.rs"
[lib]
name = "prettytable"
[dependencies]
-unicode-width = "^0.1"
-term = "^0.5"
+unicode-width = "0.1"
+term = "0.5"
lazy_static = "1"
-atty = "^0.2"
-encode_unicode = "^0.3"
+atty = "0.2"
+encode_unicode = "0.3"
csv = { version = "1", optional = true }