summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..5472a16
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "pidlock"
+version = "0.1.0"
+authors = ["Paul Hummer <paul@eventuallyanyway.com>"]
+license = "MIT"
+description = "A library for using pidfiles as resource locks"
+repository = "https://github.com/rockstar/pidlock"
+keywords = ["pidfile", "file", "filelock", "server", "lock"]
+categories = ["Filesystem"]
+readme = "README.md"
+include = [
+ "src/*.rs",
+ "Cargo.toml",
+ "README.md",
+ "LICENSE-MIT",
+ "LICENSE-APACHE",
+]
+
+
+[dependencies]
+libc = "0.2.40"
+
+travis-ci = { repository = "rockstar/pidlock" }