summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2021-09-29 18:33:38 +1000
committerDarren Tucker <dtucker@dtucker.net>2021-09-29 18:33:38 +1000
commitc9172193ea975415facf0afb356d87df21535f88 (patch)
tree06a1e8adb51bf6a02ca94e79e1bdb53189f16755 /configure.ac
parent5e6d28b7874b0deae95d2c68947c45212d32e599 (diff)
Remove TEST_SSH_ECC.
Convert the only remaining user of it to runtime detection using ssh -Q.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 821a75ba..f5fad647 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3105,8 +3105,6 @@ if test "x$openssl" = "xyes" ; then
AC_MSG_RESULT([no])
)
- TEST_SSH_ECC=no
-
if test x$enable_nistp256 = x1 || test x$enable_nistp384 = x1 || \
test x$enable_nistp521 = x1; then
AC_DEFINE(OPENSSL_HAS_ECC, [1], [OpenSSL has ECC])
@@ -3118,7 +3116,6 @@ if test "x$openssl" = "xyes" ; then
if test x$enable_nistp256 = x1; then
AC_DEFINE([OPENSSL_HAS_NISTP256], [1],
[libcrypto has NID_X9_62_prime256v1])
- TEST_SSH_ECC=yes
else
unsupported_algorithms="$unsupported_algorithms \
ecdsa-sha2-nistp256 \
@@ -3127,7 +3124,6 @@ if test "x$openssl" = "xyes" ; then
fi
if test x$enable_nistp384 = x1; then
AC_DEFINE([OPENSSL_HAS_NISTP384], [1], [libcrypto has NID_secp384r1])
- TEST_SSH_ECC=yes
else
unsupported_algorithms="$unsupported_algorithms \
ecdsa-sha2-nistp384 \
@@ -3136,7 +3132,6 @@ if test "x$openssl" = "xyes" ; then
fi
if test x$enable_nistp521 = x1; then
AC_DEFINE([OPENSSL_HAS_NISTP521], [1], [libcrypto has NID_secp521r1])
- TEST_SSH_ECC=yes
else
unsupported_algorithms="$unsupported_algorithms \
ecdh-sha2-nistp521 \
@@ -3144,7 +3139,6 @@ if test "x$openssl" = "xyes" ; then
ecdsa-sha2-nistp521-cert-v01@openssh.com"
fi
- AC_SUBST([TEST_SSH_ECC])
else
AC_CHECK_LIB([crypt], [crypt], [LIBS="$LIBS -lcrypt"])
AC_CHECK_FUNCS([crypt])