summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2021-10-28 16:24:53 +1100
committerDamien Miller <djm@mindrot.org>2021-10-28 16:24:53 +1100
commitbe28b23012aa3fa323be7ec84863cf238927c078 (patch)
tree0d4fe2ce8153ce7ca07450f18237d5e25a089f5c /configure.ac
parent2e6f5f24dd2f9217f4ab8b737ed428d5d5278f91 (diff)
use -Wmisleading-indentation cflag if available
ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f103b3bf..2a3d35da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,6 +176,7 @@ if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
OSSH_CHECK_CFLAG_COMPILE([-Wunused-parameter], [-Wno-unused-parameter])
OSSH_CHECK_CFLAG_COMPILE([-Wunused-result], [-Wno-unused-result])
OSSH_CHECK_CFLAG_COMPILE([-Wimplicit-fallthrough])
+ OSSH_CHECK_CFLAG_COMPILE([-Wmisleading-indentation])
OSSH_CHECK_CFLAG_COMPILE([-fno-strict-aliasing])
if test "x$use_toolchain_hardening" = "x1"; then
OSSH_CHECK_CFLAG_COMPILE([-mretpoline]) # clang