summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2019-11-15 18:56:54 +1100
committerDarren Tucker <dtucker@dtucker.net>2019-11-15 18:56:54 +1100
commit39b87104cdd47baf79ef77dc81de62cea07d119f (patch)
treeb5620074868fbcec1f0b346635bdf4cc49eb2b25 /configure.ac
parent134a74f4e0cf750931f1125beb2a3f40c54c8809 (diff)
Add wrappers for other ultrix headers.
Wrappers protect against multiple inclusions for headers that don't do it themselves.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 99a88d6d..cc944174 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1207,17 +1207,19 @@ mips-sony-bsd|mips-sony-newsos4)
# DISABLE_FD_PASSING so that we call setpgrp as root, otherwise we
# don't get a controlling tty.
AC_DEFINE([DISABLE_FD_PASSING], [1], [Need to call setpgrp as root])
- # On Ultrix netinet/ip.h is not protected against multiple includes,
- # so we create our own wrapper and put it where the compiler will
- # find it.
- AC_MSG_WARN([creating compat wrapper for netinet/ip.h])
+ # On Ultrix some headers are not protected against multiple includes,
+ # so we create wrappers and put it where the compiler will find it.
+ AC_MSG_WARN([creating compat wrappers for headers])
mkdir -p netinet
- cat >netinet/ip.h <<EOD
-#ifndef _SSH_COMPAT_NETINET_IP_H
-#define _SSH_COMPAT_NETINET_IP_H
-#include "/usr/include/netinet/ip.h"
+ for header in netinet/ip.h netdb.h resolv.h; do
+ name=`echo $header | tr 'a-z/.' 'A-Z__'`
+ cat >$header <<EOD
+#ifndef _SSH_COMPAT_${name}
+#define _SSH_COMPAT_${name}
+#include "/usr/include/${header}"
#endif
EOD
+ done
;;
*-*-lynxos)