summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2022-07-22 10:47:19 +1000
committerDarren Tucker <dtucker@dtucker.net>2022-07-27 16:22:39 +1000
commit099d6b56288b421ba38531d26dc1bd6bb685e311 (patch)
tree4ea25d19bef5ef8348fd5edd291af9839c0c7726 /configure.ac
parent1bdf86725b77733bb5f17c54888b88a10b2f6538 (diff)
Move libcrypto into CHANNELLIBS.
This will result in sftp, sftp-server and scp no longer being linked against libcrypto. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0044e4fe..33f9b5f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2702,8 +2702,10 @@ AC_ARG_WITH([ssl-engine],
]
)
+nocrypto_saved_LIBS="$LIBS"
if test "x$openssl" = "xyes" ; then
LIBS="-lcrypto $LIBS"
+ CHANNELLIBS="-lcrypto $CHANNELLIBS"
AC_TRY_LINK_FUNC([RAND_add], ,
[AC_MSG_ERROR([*** working libcrypto not found, check config.log])])
AC_CHECK_HEADER([openssl/opensslv.h], ,
@@ -2874,7 +2876,6 @@ if test "x$openssl" = "xyes" ; then
],
[
AC_MSG_RESULT([no])
- saved_LIBS="$LIBS"
LIBS="$LIBS -ldl"
AC_MSG_CHECKING([if programs using OpenSSL need -ldl])
AC_LINK_IFELSE(
@@ -2882,10 +2883,10 @@ if test "x$openssl" = "xyes" ; then
[[ ERR_load_crypto_strings(); ]])],
[
AC_MSG_RESULT([yes])
+ CHANNELLIBS="$CHANNELLIBS -ldl"
],
[
AC_MSG_RESULT([no])
- LIBS="$saved_LIBS"
]
)
]
@@ -3340,7 +3341,7 @@ elif test "x$openssl" = "xno" ; then
else
AC_MSG_ERROR([OpenSSH has no source of random numbers. Please configure OpenSSL with an entropy source or re-run configure using one of the --with-prngd-port or --with-prngd-socket options])
fi
-
+LIBS="$nocrypto_saved_LIBS"
saved_LIBS="$LIBS"
AC_CHECK_LIB([iaf], [ia_openinfo], [