summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorNaïm Favier <n@monade.li>2020-12-15 16:01:40 +0100
committerNaïm Favier <n@monade.li>2020-12-15 16:14:44 +0100
commitae89eafb817f6c691cb0e97f9e67cd9204ada3a4 (patch)
treea2e64d1c337e2e28514a2244b966417cff3e0aaf /shell.nix
parent7c06f610f15642e3664f01a51c08c64cc8835f51 (diff)
add flake support
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 1 insertions, 11 deletions
diff --git a/shell.nix b/shell.nix
index 2c06231..d32886e 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,11 +1 @@
-let
- nixpkgs = (import ./nix/sources.nix).nixpkgs-unstable;
- pkgs = import nixpkgs {};
-in
-pkgs.mkShell {
- buildInputs = with pkgs; [
- (python3.withPackages(p: [p.sphinx p.sphinx_rtd_theme]))
- niv
- jq clamav
- ];
-}
+(import (builtins.fetchGit "https://github.com/edolstra/flake-compat") { src = ./.; }).shellNix