summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorRuben Maher <ruben@maher.fyi>2018-08-18 13:41:48 +0930
committerRuben Maher <ruben@maher.fyi>2018-08-18 15:13:25 +0930
commit9488b6fd43de9a9274b0dbd36e2758550dd7cad3 (patch)
tree7d7428c59f8eb50aa036a57974203ff5eda718d9 /shell.nix
parent817d84d36d34616ecf1a6ed6cba4fb1327b3a74f (diff)
ci: store Clamav DB in LFS
Fix #136 (stop pulling the files from @griff's poor server), also add a script to update the files. The fun thing about this is that due to sourcing the files from `https://gitlab.com/simple-nixos-mailserver/nixos-mailserver/raw/master/tests/clamav` during the tests, updates to the `hashes.json` and `*.cvd` files will always fail CI. I guess this is a reasonable tradeoff as long as people are aware of it.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..2c0d7f6
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,9 @@
+{ nixpkgs ? <nixpkgs>, system ? builtins.currentSystem }:
+
+with (import nixpkgs { inherit system; }); stdenv.mkDerivation rec {
+ name = "nixos-mailserver-env";
+ env = buildEnv { name = name; paths = buildInputs; };
+ buildInputs = with pkgs; [
+ jq clamav
+ ];
+}