summaryrefslogtreecommitdiffstats
path: root/mail-server/networking.nix
diff options
context:
space:
mode:
authorRobin Raymond <robin@robinraymond.de>2017-08-12 11:27:19 +0200
committerRobin Raymond <robin@robinraymond.de>2017-08-12 11:27:19 +0200
commit60574841c6fd2a95dd3907c73c1f11200f637346 (patch)
treed4e125e1a65daf1551eda50f6bac23c4eaff189b /mail-server/networking.nix
parent54e56926d64a5989884c12a64cb3e05d6731782c (diff)
restructuring; now works with 17.03/17.09-pre
I had to remove some of the features, they need to be slowely added in again.
Diffstat (limited to 'mail-server/networking.nix')
-rw-r--r--mail-server/networking.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/mail-server/networking.nix b/mail-server/networking.nix
new file mode 100644
index 0000000..7f3897b
--- /dev/null
+++ b/mail-server/networking.nix
@@ -0,0 +1,26 @@
+# nixos-mailserver: a simple mail server
+# Copyright (C) 2016-2017 Robin Raymond
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>
+
+{ domain, host_prefix, ... }:
+
+{
+ hostName = host_prefix + "." + domain;
+
+ firewall = {
+ enable = true;
+ allowedTCPPorts = [ 25 143 587 ]; # < TODO: make this flexible
+ };
+}