summaryrefslogtreecommitdiffstats
path: root/mail-server/environment.nix
diff options
context:
space:
mode:
authorRobin Raymond <robin@robinraymond.de>2017-08-13 11:51:07 +0200
committerRobin Raymond <robin@robinraymond.de>2017-08-13 11:51:07 +0200
commitb68e64ec727f7c3c7fd0530f32fd2d7319a55cdd (patch)
tree1eaaf755c394c4471d658b094582bbce52077a81 /mail-server/environment.nix
parentbe5d8c09d8e14e9fab6553a121fa8f53b4dd884f (diff)
certificate scheme 2
On the fly create certificates via openssl (Maybe change this to libressl in the future?). This is probably the best scheme to get something that simply works. Self signed certificates only pose a problem when connecting to retrieve the email via imap or pop3.
Diffstat (limited to 'mail-server/environment.nix')
-rw-r--r--mail-server/environment.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail-server/environment.nix b/mail-server/environment.nix
index 7f4d5d7..3b61430 100644
--- a/mail-server/environment.nix
+++ b/mail-server/environment.nix
@@ -14,10 +14,10 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>
-{ pkgs, ... }:
+{ pkgs, certificate_scheme }:
{
systemPackages = with pkgs; [
dovecot opendkim openssh postfix clamav rspamd rmilter
- ];
+ ] ++ (if certificate_scheme == 2 then [ openssl ] else []);
}