summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorJoey Hewitt <joey@joeyhewitt.com>2019-06-29 17:56:22 -0600
committerJoey Hewitt <joey@joeyhewitt.com>2019-07-09 21:59:28 -0600
commitf789f7a80cce450c48e13fbe6fa4897354737d81 (patch)
treebd7511de088a0b6fdf398c92a58f18482d4a1db1 /default.nix
parent7e718e0e33cc3a9ae38f88a66d51c36ef44e51cb (diff)
add dkimKeyBits configuration
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 58ab271..e4d8785 100644
--- a/default.nix
+++ b/default.nix
@@ -422,6 +422,19 @@ in
'';
};
+ dkimKeyBits = mkOption {
+ type = types.int;
+ default = 1024;
+ description = ''
+ How many bits in generated DKIM keys. RFC6376 advises minimum 1024-bit keys.
+
+ If you have already deployed a key with a different number of bits than specified
+ here, then you should use a different selector (dkimSelector). In order to get
+ this package to generate a key with the new number of bits, you will either have to
+ change the selector or delete the old key file.
+ '';
+ };
+
debug = mkOption {
type = types.bool;
default = false;