summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorIzorkin <Izorkin@gmail.com>2018-11-16 14:11:31 +0300
committerIzorkin <izorkin@elven.pw>2021-12-05 20:53:21 +0300
commitf3d967f8308f0f617597ab0b96bfec3fc1aeb325 (patch)
treefdd370ca91f9f13deb2a35f1d5e9615f86e0c68a /default.nix
parent7c7ed5ce06621578b72725094cab12d6192a4598 (diff)
nginx: generate certificates for custom domains and subdomains
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index bf86e19..f46f1a4 100644
--- a/default.nix
+++ b/default.nix
@@ -44,6 +44,13 @@ in
description = "The domains that this mail server serves.";
};
+ certificateDomains = mkOption {
+ type = types.listOf types.str;
+ example = [ "imap.example.com" "pop3.example.com" ];
+ default = [];
+ description = "Secondary domains and subdomains for which it is necessary to generate a certificate.";
+ };
+
messageSizeLimit = mkOption {
type = types.int;
example = 52428800;