summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2019-10-16 21:51:45 +0200
committerAntoine Eiche <lewo@abesis.fr>2020-05-08 20:43:46 +0200
commitd47e4ead88043615c76c275879d38004c91cd264 (patch)
tree0a5a278e32b28fd9f5f38d1df963cc6ea4e1c904 /default.nix
parentb7c49fa26a66a724e4e985851e34cf76bc01c9e1 (diff)
Add send-only accounts
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 86cbe19..7e2eb6c 100644
--- a/default.nix
+++ b/default.nix
@@ -137,6 +137,26 @@ in
Per-user sieve script.
'';
};
+
+ sendOnly = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Specifies if the account should be a send-only account.
+ Emails sent to send-only accounts will be rejected with the
+ rejectMessage stating the reason.
+ '';
+ };
+
+ rejectMessage = mkOption {
+ type = types.str;
+ default = "This account cannot receive emails.";
+ description = ''
+ The message that will be returned to the sender when an email is
+ sent to a send-only account. Only used if the account is marked
+ as send-only.
+ '';
+ };
};
config.name = mkDefault name;