summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorMilan Pässler <me@pbb.lc>2020-07-06 10:38:12 +0200
committerAntoine Eiche <lewo@abesis.fr>2020-10-05 20:54:46 +0200
commitcc526a27009be1f1cfbc195f7e859f924f19ef68 (patch)
tree2044a41752b0b75369f2c38ae9ee0498ba7ec8e7 /default.nix
parent823c26fa69fcecce60a1f31610281476833a7b7e (diff)
add full support for tls wrapped mode
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix38
1 files changed, 21 insertions, 17 deletions
diff --git a/default.nix b/default.nix
index 6372574..b5c4799 100644
--- a/default.nix
+++ b/default.nix
@@ -396,21 +396,31 @@ in
type = types.bool;
default = true;
description = ''
- Whether to enable imap / pop3. Both variants are only supported in the
- (sane) startTLS configuration. The ports are
-
- 110 - Pop3
- 143 - IMAP
- 587 - SMTP with login
+ Whether to enable IMAP with STARTTLS on port 143.
'';
};
enableImapSsl = mkOption {
type = types.bool;
- default = false;
+ default = true;
+ description = ''
+ Whether to enable IMAP with TLS in wrapper-mode on port 993.
+ '';
+ };
+
+ enableSubmission = mkOption {
+ type = types.bool;
+ default = true;
+ description = ''
+ Whether to enable SMTP with STARTTLS on port 587.
+ '';
+ };
+
+ enableSubmissionSsl = mkOption {
+ type = types.bool;
+ default = true;
description = ''
- Whether to enable IMAPS, setting this option to true will open port 993
- in the firewall.
+ Whether to enable SMTP with TLS in wrapper-mode on port 465.
'';
};
@@ -418,12 +428,7 @@ in
type = types.bool;
default = false;
description = ''
- Whether to enable POP3. Both variants are only supported in the (sane)
- startTLS configuration. The ports are
-
- 110 - Pop3
- 143 - IMAP
- 587 - SMTP with login
+ Whether to enable POP3 with STARTTLS on port on port 110.
'';
};
@@ -431,8 +436,7 @@ in
type = types.bool;
default = false;
description = ''
- Whether to enable POP3S, setting this option to true will open port 995
- in the firewall.
+ Whether to enable POP3 with TLS in wrapper-mode on port 995.
'';
};