summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorMichishige Kaito <me@mkaito.com>2018-11-23 14:29:23 +0000
committerMichishige Kaito <me@mkaito.com>2018-11-23 14:29:23 +0000
commitc2ca4d1bb05a5c3886b433dc10b2c4d55bfa1f29 (patch)
tree617e768b05ff0486999e620e4ba02ae2256b4bdb /default.nix
parentebf34930a7d6f290cfc9fd3c492d9ae584ef6ece (diff)
postfix: allow configuring message_size_limit
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index db68f2e..58ab271 100644
--- a/default.nix
+++ b/default.nix
@@ -39,6 +39,13 @@ in
description = "The domains that this mail server serves.";
};
+ messageSizeLimit = mkOption {
+ type = types.int;
+ example = 52428800;
+ default = 20971520;
+ description = "Message size limit enforced by Postfix.";
+ };
+
loginAccounts = mkOption {
type = types.loaOf (types.submodule ({ name, ... }: {
options = {