summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorRobin Raymond <robin@robinraymond.de>2018-11-10 14:29:16 +0100
committerRobin Raymond <robin@robinraymond.de>2018-11-10 14:29:16 +0100
commitacd65c080392cf2f45aa6b563e2daed979d87b18 (patch)
treea2643307f58b2c063aa02cd10b7a6b3217f6bf4e /default.nix
parent28cff2497add3a3186db7e9c6dbba285ea7e98d0 (diff)
New Feature >>rejectSender<<
Authored by tokudan
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 010f224..db68f2e 100644
--- a/default.nix
+++ b/default.nix
@@ -166,6 +166,16 @@ in
default = {};
};
+ rejectSender = mkOption {
+ type = types.listOf types.str;
+ example = [ "@example.com" "spammer@example.net" ];
+ description = ''
+ Reject emails from these addresses from unauthorized senders.
+ Use if a spammer is using the same domain or the same sender over and over.
+ '';
+ default = [];
+ };
+
rejectRecipients = mkOption {
type = types.listOf types.str;
example = [ "sales@example.com" "info@example.com" ];