summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorAntoine Eiche <lewo@abesis.fr>2021-07-23 23:21:36 +0200
committerAntoine Eiche <lewo@abesis.fr>2021-07-24 09:57:44 +0200
commit9578dbac69ec3ddf9b2fd38a40d74332b7454dfa (patch)
tree4c4c6f569c83dcc65398c52ef64243c4c59901ff /default.nix
parent864ea5bfeff7f9a0380f03b9c325ca0233a77bf5 (diff)
Remove non longer supported configurations (<21.05)cleaning
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix37
1 files changed, 17 insertions, 20 deletions
diff --git a/default.nix b/default.nix
index dd800b1..5d94438 100644
--- a/default.nix
+++ b/default.nix
@@ -421,27 +421,24 @@ in
The mailboxes for dovecot.
Depending on the mail client used it might be necessary to change some mailbox's name.
'';
- default = let
- defMailBoxes = {
- Trash = {
- auto = "no";
- specialUse = "Trash";
- };
- Junk = {
- auto = "subscribe";
- specialUse = "Junk";
- };
- Drafts = {
- auto = "subscribe";
- specialUse = "Drafts";
- };
- Sent = {
- auto = "subscribe";
- specialUse = "Sent";
- };
+ default = {
+ Trash = {
+ auto = "no";
+ specialUse = "Trash";
};
- in if (versionAtLeast version "20.09pre") then defMailBoxes
- else (flip mapAttrsToList defMailBoxes (name: options: { inherit name; } // options));
+ Junk = {
+ auto = "subscribe";
+ specialUse = "Junk";
+ };
+ Drafts = {
+ auto = "subscribe";
+ specialUse = "Drafts";
+ };
+ Sent = {
+ auto = "subscribe";
+ specialUse = "Sent";
+ };
+ };
};
certificateScheme = mkOption {