summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorHenri Menke <henri@henrimenke.de>2020-11-29 10:58:16 +0100
committerAntoine Eiche <lewo@abesis.fr>2020-11-29 20:19:46 +0100
commit89bd89c706c9862c6980cdf18a74ad041f98dc76 (patch)
tree0e18e76223b830ed8022466f3bdd17bcaa4af6a4 /default.nix
parentc00fc587f5cbdc9e498f00a6ec6dafe164c00289 (diff)
Recommend bcrypt passwords everywhere
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/default.nix b/default.nix
index 5ebb391..7452ebd 100644
--- a/default.nix
+++ b/default.nix
@@ -59,10 +59,10 @@ in
default = null;
example = "$6$evQJs5CFQyPAW09S$Cn99Y8.QjZ2IBnSu4qf1vBxDRWkaIZWOtmu1Ddsm3.H3CFpeVc0JU4llIq8HQXgeatvYhh5O33eWG3TSpjzu6/";
description = ''
- The user's hashed password. Use `mkpasswd` as follows
+ The user's hashed password. Use `htpasswd` as follows
```
- mkpasswd -m sha-512 "super secret password"
+ nix run nixpkgs.apacheHttpd -c htpasswd -nbB "" "super secret password" | cut -d: -f2
```
Warning: this is stored in plaintext in the Nix store!
@@ -75,10 +75,10 @@ in
default = null;
example = "/run/keys/user1-passwordhash";
description = ''
- A file containing the user's hashed password. Use `mkpasswd` as follows
+ A file containing the user's hashed password. Use `htpasswd` as follows
```
- mkpasswd -m sha-512 "super secret password"
+ nix run nixpkgs.apacheHttpd -c htpasswd -nbB "" "super secret password" | cut -d: -f2
```
'';
};
@@ -171,11 +171,11 @@ in
};
description = ''
The login account of the domain. Every account is mapped to a unix user,
- e.g. `user1@example.com`. To generate the passwords use `mkpasswd` as
+ e.g. `user1@example.com`. To generate the passwords use `htpasswd` as
follows
```
- mkpasswd -m sha-512 "super secret password"
+ nix run nixpkgs.apacheHttpd -c htpasswd -nbB "" "super secret password" | cut -d: -f2
```
'';
default = {};