summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorBrian Olsen <brian@maven-group.org>2018-05-17 02:01:49 +0200
committerRuben Maher <ruben@maher.fyi>2018-06-29 21:36:34 +0930
commit88e292c5b7a7cf675fba418cb2f6c4421496863b (patch)
tree7805059d6d23b58c9a743513bf8b3309df5f2c84 /default.nix
parent61df799036bafa3cf39d1fab39d7ad5110e67c12 (diff)
postfix: Support setting options for policyd-spf
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 376d47a..0134541 100644
--- a/default.nix
+++ b/default.nix
@@ -454,6 +454,18 @@ in
'';
};
+ policydSPFExtraConfig = mkOption {
+ type = types.lines;
+ default = "";
+ example = ''
+ skip_addresses = 127.0.0.0/8,::ffff:127.0.0.0/104,::1
+ '';
+ description = ''
+ Extra configuration options for policyd-spf. This can be use to among
+ other things skip spf checking for some IP addresses.
+ '';
+ };
+
monitoring = {
enable = mkEnableOption "monitoring via monit";