summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorRuben Maher <r@rkm.id.au>2017-11-13 09:29:29 +1030
committerRuben Maher <r@rkm.id.au>2017-11-13 20:10:30 +1030
commit5047c2982f07dd581b78261fbfe792b83c71da7d (patch)
tree06125804102edad7db2de313a2b8071fce03e9b8 /default.nix
parenta12c42bdfb645d6729403c1d552369a1076f35db (diff)
default.nix: add options to open ports 993 (IMAPS) and 995 (POP3S)
Dovecot is already configured to serve IMAPS on port 993 and POP3S on port 995.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix25
1 files changed, 20 insertions, 5 deletions
diff --git a/default.nix b/default.nix
index d5cb669..4de34f5 100644
--- a/default.nix
+++ b/default.nix
@@ -184,7 +184,7 @@ in
default = true;
description = ''
Whether to enable imap / pop3. Both variants are only supported in the
- (sane) startTLS configuration. (TODO: Allow SSL ports). The ports are
+ (sane) startTLS configuration. The ports are
110 - Pop3
143 - IMAP
@@ -192,12 +192,21 @@ in
'';
};
+ enableImapSsl = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Whether to enable IMAPS, setting this option to true will open port 993
+ in the firewall.
+ '';
+ };
+
enablePop3 = mkOption {
type = types.bool;
default = false;
description = ''
- Whether to enable POP3. Both variants are only supported in the
- (sane) startTLS configuration. (TODO: Allow SSL ports). The ports are
+ Whether to enable POP3. Both variants are only supported in the (sane)
+ startTLS configuration. The ports are
110 - Pop3
143 - IMAP
@@ -205,8 +214,14 @@ in
'';
};
- # imapSsl = mkOption {} #< TODO
- # pop3Ssl = mkOption {} #< TODO
+ enablePop3Ssl = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Whether to enable POP3S, setting this option to true will open port 995
+ in the firewall.
+ '';
+ };
virusScanning = mkOption {
type = types.bool;