summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorPhilipp Dörfler <phdoerfler@gmail.com>2018-03-13 10:43:30 +0000
committerPhilipp Dörfler <phdoerfler@gmail.com>2018-03-13 10:43:30 +0000
commit4f36b72dd6a4602b3af0879b47beb899858735ca (patch)
treeabb7a1f9bd2b782abc1374804302a7995968734c /default.nix
parente3a12093b7631677443637f87aed8406b2f41285 (diff)
Added dovecot option for mail_max_userip_connections defaulting to 100
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 77dca63..43041a5 100644
--- a/default.nix
+++ b/default.nix
@@ -408,12 +408,22 @@ in
type = types.bool;
default = false;
description = ''
- Whether to enable verbose logging for mailserver related services. This
+ Whether to enable verbose logging for mailserver related services. This
intended be used for development purposes only, you probably don't want
to enable this unless you're hacking on nixos-mailserver.
'';
};
+ maxConnectionsPerUser = mkOption {
+ type = types.int;
+ default = 100;
+ description = ''
+ Maximum number of IMAP/POP3 connections allowed for a user from each IP address.
+ E.g. a value of 50 allows for 50 IMAP and 50 POP3 connections at the same
+ time for a single user.
+ '';
+ };
+
localDnsResolver = mkOption {
type = types.bool;
default = true;