summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorEro Sennin <ag.services@sologoc.com>2021-10-14 18:45:21 +0000
committerlewo <lewo@abesis.fr>2021-10-14 18:45:21 +0000
commit0d9a880c0e41a553c5d9af4efa62169db7ddeb62 (patch)
tree1417ae33f016e1a18f5e9c5bf3be48f9af560332 /default.nix
parentacaba31d8f35f640e21a88f1c0719f74b3146568 (diff)
Set DKIM policy to relaxed/relaxed
And make this policy configurable.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 5d94438..6bb0c23 100644
--- a/default.nix
+++ b/default.nix
@@ -600,6 +600,26 @@ in
'';
};
+ dkimHeaderCanonicalization = mkOption {
+ type = types.enum ["relaxed" "simple"];
+ default = "relaxed";
+ description = ''
+ DKIM canonicalization algorithm for message headers.
+
+ See https://datatracker.ietf.org/doc/html/rfc6376/#section-3.4 for details.
+ '';
+ };
+
+ dkimBodyCanonicalization = mkOption {
+ type = types.enum ["relaxed" "simple"];
+ default = "relaxed";
+ description = ''
+ DKIM canonicalization algorithm for message bodies.
+
+ See https://datatracker.ietf.org/doc/html/rfc6376/#section-3.4 for details.
+ '';
+ };
+
debug = mkOption {
type = types.bool;
default = false;