summaryrefslogtreecommitdiffstats
path: root/inversepath/usbarmory/host.nix
diff options
context:
space:
mode:
Diffstat (limited to 'inversepath/usbarmory/host.nix')
-rw-r--r--inversepath/usbarmory/host.nix43
1 files changed, 14 insertions, 29 deletions
diff --git a/inversepath/usbarmory/host.nix b/inversepath/usbarmory/host.nix
index 87d4d95..42cef49 100644
--- a/inversepath/usbarmory/host.nix
+++ b/inversepath/usbarmory/host.nix
@@ -1,34 +1,19 @@
-#
-# Module for hosting the USB Armory
-#
-
-{ ... }:
-
-let
- staticDevName = "armory0";
-in
+{ dev ? "armory0" }:
{
- imports = [ ../../lib/hardware-notes.nix ];
-
- hardwareNotes =
- [ { title = "USB Armory network interface support";
- text =
- '' - rename the Armory USB network interface
- - set Armory inteface ip to 10.0.0.2/24
- - enable NAT and forward Armory interface
- - add the name 'armory' to /etc/hosts
- '';
- }
- ];
+ services.udev.extraRules = ''
+ SUBSYSTEM=="net", ACTION=="add", ATTRS{idVendor}=="0525", ATTRS{idProduct}=="a4a2", NAME="${staticDevName}"
+ '';
- services.udev.extraRules =
- ''SUBSYSTEM=="net", ACTION=="add", ATTRS{idVendor}=="0525", ATTRS{idProduct}=="a4a2", NAME="${staticDevName}"'';
-
- networking =
- { interfaces."${staticDevName}".ip4 = [{ address = "10.0.0.2"; prefixLength = 24; }];
- nat = { enable = true; internalInterfaces = [ staticDevName ]; };
- extraHosts = "10.0.0.1 armory";
+ networking = {
+ interfaces."${staticDevName}".ip4 = [{
+ address = "10.0.0.2";
+ prefixLength = 24;
+ }];
+ nat = {
+ enable = true;
+ internalInterfaces = [ dev ];
};
-
+ extraHosts = "10.0.0.1 armory";
+ };
}