summaryrefslogtreecommitdiffstats
path: root/apple/macbook-pro-10-1.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apple/macbook-pro-10-1.nix')
-rw-r--r--apple/macbook-pro-10-1.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/apple/macbook-pro-10-1.nix b/apple/macbook-pro-10-1.nix
new file mode 100644
index 0000000..f9ba24d
--- /dev/null
+++ b/apple/macbook-pro-10-1.nix
@@ -0,0 +1,41 @@
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ ../lib/kernel-version.nix
+ ];
+
+ ## BEGIN from generated hardware-configuration
+ ## Probably better to just use a freshly generated hardware.configuration.nix
+ ## than this, but including for reference.
+ #imports =
+ # [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ # ];
+ #
+ #boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usbhid" "sd_mod" "sdhci_pci" ];
+ #boot.kernelModules = [ "kvm-intel" "wl" ];
+ #boot.extraModulePackages = [ config.boot.kernelPackages.broadcom_sta ];
+ #
+ #nix.maxJobs = lib.mkDefault 8;
+ ## END from generated hardware-configuration
+
+ # Use the systemd-boot efi boot loader. (From default generated configuration.nix)
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ # I use this but not sure whether its needed.
+ # Right click does *NOT* work
+ services.xserver.libinput.enable = true;
+
+ kernelAtleast =
+ [ { version = "4.7"; msg = "Broadcom WiFi confirmed not to work."; }
+ ];
+
+ # Couldn't get X to work with nvidia
+ # Also, PTYs don't work after X/nvidia starts
+ services.xserver.videoDrivers = [ "nvidia" ];
+ hardware.opengl.driSupport32Bit = true;
+
+ # Seems to improve battery life *and* keep the CPU cooler
+ services.mbpfan.enable = true;
+}