summaryrefslogtreecommitdiffstats
path: root/acer/4810t.nix
diff options
context:
space:
mode:
Diffstat (limited to 'acer/4810t.nix')
-rw-r--r--acer/4810t.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/acer/4810t.nix b/acer/4810t.nix
new file mode 100644
index 0000000..ce1091b
--- /dev/null
+++ b/acer/4810t.nix
@@ -0,0 +1,37 @@
+/* imported from https://nixos.org/wiki/Acer_4810T */
+
+{ config, pkgs, lib, ... }:
+
+{
+ # Make te network WLAN card (wlan0) firmware available
+ require = [ <nixpkgs>/nixos/modules/hardware/network/intel-5000.nix ];
+
+ boot = rec {
+ initrd.kernelModules = [ "ata_piix" ];
+ kernelParams = [
+ "apm=on"
+ "acpi=on"
+ "vga=0x317"
+ "video=vesafb:ywrap"
+ # Important, to disable Kernel Mode Setting for the graphics card
+ # This will allow backlight regulation
+ "nomodeset"
+ ];
+ kernelModules = [
+ "kvm-intel"
+ ];
+ };
+
+ services = {
+ xserver = {
+ enable = true;
+ defaultDepth = 24;
+ videoDriver = "intel";
+ autorun = true;
+ driSupport = false;
+ synaptics = {
+ enable = true;
+ dev = "/dev/input/event8";
+ };
+ };
+};