summaryrefslogtreecommitdiffstats
path: root/tests/build-profile.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2020-03-11 09:46:57 +0000
committerGitHub <noreply@github.com>2020-03-11 09:46:57 +0000
commit62d7c2eddf7d7cf4bb0fd10da37970a4caaca9d3 (patch)
treeeaef6b8e2bc902320bb942b742adc0a2d83f8b8b /tests/build-profile.nix
parent62a1812f3c20b7119013650f926806fecd956574 (diff)
parent9c952961f1f1a643b8b8e5d4efab6717afec1bbe (diff)
Merge pull request #147 from Mic92/fix-travis
travis: parallelize evaluation and limit RAM usage
Diffstat (limited to 'tests/build-profile.nix')
-rw-r--r--tests/build-profile.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/build-profile.nix b/tests/build-profile.nix
new file mode 100644
index 0000000..c4509d3
--- /dev/null
+++ b/tests/build-profile.nix
@@ -0,0 +1,19 @@
+{ profile }:
+
+let
+ shim = {
+ boot.loader.systemd-boot.enable = true;
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/00000000-0000-0000-0000-000000000000";
+ fsType = "btrfs";
+ };
+
+ nixpkgs.config = {
+ allowBroken = true;
+ allowUnfree = true;
+ };
+ };
+in (import <nixpkgs/nixos> {
+ configuration.imports = [ profile shim ];
+}).system