summaryrefslogtreecommitdiffstats
path: root/lenovo/thinkpad/x230/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-26 22:54:10 +0100
committermakefu <github@syntax-fehler.de>2017-12-27 07:03:39 +0100
commit1cb3a1c2d791ec8bbae4ab18fdc9167280554bd2 (patch)
treed284fb8a1b17edc0d443e3b21b7c632f89c086bd /lenovo/thinkpad/x230/default.nix
parentd1d99eb15887cedb0d6dba66e4482c53cb809c1d (diff)
thinkpad/x230: init
Diffstat (limited to 'lenovo/thinkpad/x230/default.nix')
-rw-r--r--lenovo/thinkpad/x230/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/lenovo/thinkpad/x230/default.nix b/lenovo/thinkpad/x230/default.nix
new file mode 100644
index 0000000..daeda9e
--- /dev/null
+++ b/lenovo/thinkpad/x230/default.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+
+with lib; {
+ imports = [
+ ../.
+ ../../../common/cpu/intel
+ ];
+
+ boot = {
+ kernelModules = [
+ "acpi_call"
+ "tpm-rng"
+ ];
+ extraModulePackages = with config.boot.kernelPackages; [
+ acpi_call
+ ];
+ };
+
+ hardware.opengl.extraPackages = with pkgs; [
+ vaapiIntel
+ vaapiVdpau
+ libvdpau-va-gl
+ ];
+}