summaryrefslogtreecommitdiffstats
path: root/dell/xps/15-7590/default.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2020-02-04 11:52:02 +0000
committerGitHub <noreply@github.com>2020-02-04 11:52:02 +0000
commitcc7140b4bf3c8a6fb8d6a46cf98768eee94fcaea (patch)
treec3300b98f5f4765d911358a71bfcbb5da2b6945a /dell/xps/15-7590/default.nix
parent89c4ddb0e60e5a643ab15f68b2f4ded43134f492 (diff)
parent22a16c801ccc908e6d4c8893e0bdf7e38e623e89 (diff)
Merge pull request #114 from tomberek/master
Initial 15-7590
Diffstat (limited to 'dell/xps/15-7590/default.nix')
-rw-r--r--dell/xps/15-7590/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/dell/xps/15-7590/default.nix b/dell/xps/15-7590/default.nix
new file mode 100644
index 0000000..cad9ba6
--- /dev/null
+++ b/dell/xps/15-7590/default.nix
@@ -0,0 +1,39 @@
+{ lib, ... }:
+
+{
+ imports = [
+ ../../../common/cpu/intel
+ ../../../common/pc/laptop
+ ../../../common/pc/ssd
+ ];
+
+ # Set to true for just the first run, then disable it.
+ # boot.loader.efi.canTouchEfiVariables = lib.mkDefault true;
+
+ # Earlier font-size setup
+ console.earlySetup = true;
+
+ # Prevent small EFI partiion from filling up
+ boot.loader.grub.configurationLimit = 10;
+
+ # The 48.ucode causes the Killer wifi card to crash.
+ # The iwlfwifi-cc-a0-46.ucode works perfectly
+ nixpkgs.pkgs = import <nixpkgs> {
+ config.allowUnfree = true;
+ overlays = [
+ (self: super: {
+ firmwareLinuxNonfree = super.firmwareLinuxNonfree.overrideAttrs (old: {
+ src = super.fetchgit{
+ url = "https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git";
+ rev = "bf13a71b18af229b4c900b321ef1f8443028ded8";
+ sha256 = "1dcaqdqyffxiadx420pg20157wqidz0c0ca5mrgyfxgrbh6a4mdj";
+ };
+ postInstall = ''
+ rm $out/lib/firmware/iwlwifi-cc-a0-48.ucode
+ '';
+ outputHash = "0dq48i1cr8f0qx3nyq50l9w9915vhgpwmwiw3b4yhisbc3afyay4";
+ });
+ })
+ ];
+ };
+}