summaryrefslogtreecommitdiffstats
path: root/dell/xps/13-9360/qca6174-firmware.nix
diff options
context:
space:
mode:
authorYegor Timoshenko <yegortimoshenko@riseup.net>2018-05-15 19:54:18 +0300
committerYegor Timoshenko <yegortimoshenko@riseup.net>2018-05-15 19:54:45 +0300
commit0794564c45956c1b4711b38d2a2d43d85d12cbae (patch)
treec24ea37d963bc8cdc5c2eb03fdd2de9a21b90bfa /dell/xps/13-9360/qca6174-firmware.nix
parentb586e1051bcc2b68f3ed3fc725cbd43912ec8489 (diff)
dell/xps/13-9360: review
Diffstat (limited to 'dell/xps/13-9360/qca6174-firmware.nix')
-rw-r--r--dell/xps/13-9360/qca6174-firmware.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/dell/xps/13-9360/qca6174-firmware.nix b/dell/xps/13-9360/qca6174-firmware.nix
new file mode 100644
index 0000000..930107d
--- /dev/null
+++ b/dell/xps/13-9360/qca6174-firmware.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+ name = "${target}-firmware-${version}";
+ version = "${branch}-00042";
+
+ branch = "4.4.1.c1";
+ target = "QCA6174";
+
+ src = fetchurl {
+ url = "https://github.com/kvalo/ath10k-firmware/raw/master/${target}/hw3.0/${branch}/firmware-6.bin_RM.${version}-QCARMSWP-1";
+ sha256 = "01vvz3qhqw5l3yilcqgk1spk4y9k4qy7na7a57cbl037r231szdh";
+ };
+
+ buildCommand = ''
+ install -D $src $out/lib/firmware/ath10k/${target}/hw3.0/firmware-6.bin
+ '';
+
+ meta = with stdenv.lib; {
+ description = "Updated firmware for the qca6174 wireless chip";
+ homepage = "https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0";
+ license = licenses.unfreeRedistributable;
+ maintainers = with maintainers; [ yorickvp ];
+ platforms = platforms.linux;
+ };
+}