summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorYegor Timoshenko <yegortimoshenko@riseup.net>2018-07-17 15:27:07 +0300
committerYegor Timoshenko <yegortimoshenko@riseup.net>2018-07-17 15:27:07 +0300
commit043605cfec0344b029947c306957695a2b1a1d4d (patch)
tree2b77ce9569853392c1c52630c617351a08b9feca /default.nix
parent585a13d8b929aba086bed5f1fa3317afd30c39b3 (diff)
Fix tests
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix47
1 files changed, 46 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index c157af7..bf72211 100644
--- a/default.nix
+++ b/default.nix
@@ -1 +1,46 @@
-{ ... }: {}
+{ ... }:
+
+let
+ shim = {
+ boot.loader.systemd-boot.enable = true;
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/00000000-0000-0000-0000-000000000000";
+ fsType = "btrfs";
+ };
+
+ nixpkgs.config = {
+ allowBroken = true;
+ allowUnfree = true;
+ };
+ };
+
+ buildProfile = profile: (import <nixpkgs/nixos> {
+ configuration.imports = [ profile shim ];
+ }).system;
+in
+
+{
+ acer-aspire-4810t = buildProfile ./acer/aspire/4810t;
+
+ airis-n990 = buildProfile ./airis/n990;
+
+ apple-macbook-air-4 = buildProfile ./apple/macbook-air/4;
+ apple-macbook-air-6 = buildProfile ./apple/macbook-air/6;
+ apple-macbook-pro-10-1 = buildProfile ./apple/macbook-pro/10-1;
+ apple-macbook-pro-12-1 = buildProfile ./apple/macbook-pro/12-1;
+
+ dell-xps-15-9550 = buildProfile ./dell/xps/15-9550;
+
+ lenovo-thinkpad-t410 = buildProfile ./lenovo/thinkpad/t410;
+ lenovo-thinkpad-t440p = buildProfile ./lenovo/thinkpad/t440p;
+ lenovo-thinkpad-t460s = buildProfile ./lenovo/thinkpad/t460s;
+ lenovo-thinkpad-x140e = buildProfile ./lenovo/thinkpad/x140e;
+ lenovo-thinkpad-x220 = buildProfile ./lenovo/thinkpad/x220;
+ lenovo-thinkpad-x230 = buildProfile ./lenovo/thinkpad/x230;
+ lenovo-thinkpad-x250 = buildProfile ./lenovo/thinkpad/x250;
+
+ microsoft-surface-pro-3 = buildProfile ./microsoft/surface-pro/3;
+
+ pcengines-apu = buildProfile ./pcengines/apu;
+}