summaryrefslogtreecommitdiffstats
path: root/airis/n990/default.nix
diff options
context:
space:
mode:
authorYegor Timoshenko <yegortimoshenko@gmail.com>2017-12-22 20:17:00 +0300
committerzimbatm <zimbatm@zimbatm.com>2017-12-22 17:17:00 +0000
commit3c9f432a7146115b2d0b6200c4c19101c29caaba (patch)
tree0e0a9c6ab58f8eda82624a5b7f7238fefb6244ed /airis/n990/default.nix
parent3f2fbacb216c8905f8ca15d2c24fe95472fb9ab2 (diff)
treewide: modules -> profiles, separate dirs, list in README (#29)
Enforce proper naming: all paths are lowercase and hyphen-separated, if there's a line of models (aspire, macbook-pro, thinkpad) it becomes a subdirectory. Documentation for profiles is moved to README files in respective directories. Add an Org mode table that lists all available profiles and their paths. Instead of fetching repo locally, use a Nix channel. Making hardware profiles read-only should improve quality and amount of participation long-term.
Diffstat (limited to 'airis/n990/default.nix')
-rw-r--r--airis/n990/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/airis/n990/default.nix b/airis/n990/default.nix
new file mode 100644
index 0000000..b3056b7
--- /dev/null
+++ b/airis/n990/default.nix
@@ -0,0 +1,22 @@
+{ ... }:
+
+{
+ boot = {
+ initrd.kernelModules = [ "pata_via" ];
+
+ kernelParams = [
+ "apm=on"
+ "acpi=on"
+ "vga=0x317" # 1024x768
+ "console=tty1"
+ "video=vesafb:ywrap" # Faster scroll
+ ];
+ };
+
+ services.xserver = {
+ videoDriver = "unichrome";
+ synaptics.enable = true;
+ };
+
+ networking.enableIntel2200BGFirmware = true;
+}