summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-03-13 14:40:15 +0100
committerEelco Dolstra <edolstra@gmail.com>2017-03-15 16:49:06 +0100
commite8186085e07104d4b844208613c2d704b5b57dec (patch)
treecce5074dd45b109c0edd5427fa06c4f8ec668bbe /release.nix
parent73d7a51ee6942f681db468dc8e3c631b4d3daa4e (diff)
Add support for brotli compression
Build logs on cache.nixos.org are compressed using Brotli (since this allows them to be decompressed automatically by Chrome and Firefox), so it's handy if "nix log" can decompress them.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index e61e81bdf..a266af7c2 100644
--- a/release.nix
+++ b/release.nix
@@ -24,7 +24,8 @@ let
inherit officialRelease;
buildInputs =
- [ curl bison flex perl libxml2 libxslt bzip2 xz
+ [ curl bison flex perl libxml2 libxslt
+ bzip2 xz brotli
pkgconfig sqlite libsodium boehmgc
docbook5 docbook5_xsl
autoconf-archive
@@ -73,7 +74,10 @@ let
src = tarball;
buildInputs =
- [ curl perl bzip2 xz openssl pkgconfig sqlite boehmgc ]
+ [ curl perl
+ bzip2 xz brotli
+ openssl pkgconfig sqlite boehmgc
+ ]
++ lib.optional (stdenv.isLinux || stdenv.isDarwin) libsodium
++ lib.optional (stdenv.isLinux || stdenv.isDarwin)
(aws-sdk-cpp.override {