summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2020-10-15 18:54:36 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2020-10-15 18:54:36 +0000
commitf6ed1a96b397f0345af029127cfde86bcd0247d2 (patch)
tree4dacb01c05e52f3cf188749ee3228cfc2fe76334 /flake.nix
parent39de73550dd5579c2b3f14f7ce669d3f8ed85689 (diff)
`build-static` -> `buildStatic` in Nix's flake
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index a5710f608..0602861fa 100644
--- a/flake.nix
+++ b/flake.nix
@@ -228,7 +228,7 @@
# Binary package for various platforms.
build = nixpkgs.lib.genAttrs systems (system: self.packages.${system}.nix);
- build-static = nixpkgs.lib.genAttrs linuxSystems (system: self.packages.${system}.nix-static);
+ buildStatic = nixpkgs.lib.genAttrs linuxSystems (system: self.packages.${system}.nix-static);
# Perl bindings for various platforms.
perlBindings = nixpkgs.lib.genAttrs systems (system: self.packages.${system}.nix.perl-bindings);
@@ -441,7 +441,7 @@
binaryTarball = self.hydraJobs.binaryTarball.${system};
perlBindings = self.hydraJobs.perlBindings.${system};
} // nixpkgs.lib.optionalAttrs (builtins.elem system linuxSystems) {
- build-static = self.hydraJobs.build-static.${system};
+ buildStatic = self.hydraJobs.buildStatic.${system};
});
packages = forAllSystems (system: {